Monday, June 08

Blog

Mooving

mee.nu (and the mu.nu Minx blogs) will be migrating across to its new home on Monday at 6AM GMT.

Was originally scheduled for Sunday at the same time, but I somehow slept through all of Saturday, so I'm not quite ready yet.

Downtime is expected to be about an hour.  Originally it was going to be just a few minutes, but due to recent hiccups I'm now planning to do a full database reload, so it will take a little longer.

Update: Running a bit behind schedule, bit still planning to do the move today.  I have worked out a plan to minimise the downtime, so when your blog goes blank for twenty minutes or so, that will be it.

(I should be able to put up a message saying what's happening.)

Update: Still working on it.  Tidying up the old environment now so that I can do a nice quick move.  While I'm doing that, I'll do a test run of the database load.

Update: Downtime should be only about 15 minutes.  The trial run took 3.5 minutes to dump the database, 1 minute to copy across to the new server, and 8.5 minutes to load.  That's not at all bad.

The setup is nearly ready, so I'm going to proceed and get it done before the database glitches again. frown

Update: Damn.  The database dump doesn't work correctly if there are corrupt indexes, so I'll have to do an index rebuild first, then dump.

Update: Ran into a bug.  Looks like it's not happening today after all.  I'll keep working on it and reschedule, probably to tomorrow.

Update: Doh!  I know what's going on.  Hang on...

Update: Nope, that wasn't it. sad   Weird.  I'm already running a CherryPy app in production on this server, so why won't this one start?  I can't even get a trivial sample program to run.  Same version of Python and CherryPy too.  Hmm.

Update: Foo.  Networking wasn't running correctly on the newly-created virtual server.  I restarted it, and everything is fine.  It looked like a firewall issue - with the new system, not only is the server protected from the outside world, but all the virtual servers are protected from each other, and, in fact, from themselves.  But no, it was just that the loopback interface wasn't running.

Update: Okay, looks like the application server and database are working fine now.  Just need to set up the load-balancer.  But it's nearly midnight, so I won't be doing the move today; it will be tomorrow instead.

Posted by: Pixy Misa at 11:42 PM | Comments (5) | Add Comment | Trackbacks (Suck)
Post contains 423 words, total size 3 kb.

1 Just testing...

Posted by: Pixy Misa at Tuesday, June 09 2009 04:40 AM (PiXy!)

2 Okay.

Posted by: Pixy Misa at Tuesday, June 09 2009 04:40 AM (PiXy!)

3 Good.

Posted by: Pixy Misa at Tuesday, June 09 2009 04:40 AM (PiXy!)

4 Is it soup yet?

Posted by: Steven Den Beste at Tuesday, June 09 2009 02:25 PM (+rSRq)

5 Not yet, sorry.

Posted by: Pixy Misa at Tuesday, June 09 2009 02:51 PM (PiXy!)

Hide Comments | Add Comment

Post is locked.
35kb generated in CPU 0.03, elapsed 0.0544 seconds.
51 queries taking 0.0428 seconds, 150 records returned.
Powered by Minx 1.1.6c-pink.